Thursday, May 24, 2012

Index was outside the bounds of the array


I was trying to connect to SQLserver 2012 using SQLserver 2008 Management studio and received below error. I was able to connect and able to query.




I tried the same with SQL2005 Management studio and same error. I didn’t see useful information under Technical details.



Cause: Please note that old versions of SSMS (SQLServer Management Studio) are not forward compatible. Using 2012 SSMS you can connect to SQLServer 2005/2008 databases as it is backward compatible.


It looks like Microsoft will not fix the forward compatiable.


Solution: Upgrade all your client tools to highest version, and then you won't be missing out on any functionality or getting error messages.


Regards,

Satishbabu Gunukula

1 comment: